Taming An Erratic Tachometer


Tag: engine diagnostics

Courtesy of the C380 List and Tom Soko, Juniper, C400 #307:

It might not be as bad as you think. When I bought my 400 in 2009, I noticed the same symptoms with the tach. Sometimes accurate, but mostly very high readings (I knew the engine wasn't idling at 4k!), and the tach varied quite a bit while the engine was stable at one RPM. I first checked all electrical connections, and they were all tight. I talked with Dennis at Seaward Products. They build all the engine and electrical panels for CY, and have done so for many years. Dennis is the panel guru, and most likely assembled your panel (yes, him personally!). He suggested using a small screwdriver and moving the selector screw back and forth a bunch of times (the A-B-C-D screw in the back of the tach). He said that the internal contacts sometimes get corroded, and that by moving the screw, the contacts are somewhat cleaned. Sort of like old-fashioned TV sets with manual tuners. The contacts get dirty and need to be cleaned. My selector screw was fixed in place by a small drop of ?lacquer?, but Dennis said not to worry about it, it's OK to break the "seal". He told me he put the drop there to keep "happy hands" away. After you move the selector switch, you can put a drop of nail polish on it if you want to, but it's not necessary. BTW, my tach has been working well for the past 1.5 yrs after I cleaned the contacts. Hope this helps.


by Jeffrey Hare

C320 Woodbine II #809

Website Slave
YahooIM ID: jeffhare320

Share It!

Login required to comment
Photo Gallery
LED Strip Lighting Underneath Side of Headliner
Who's Online
Guest Users: 215
What's New
No New Items